Wikka Documentation : Installing137

HomePage :: Index :: RecentChanges :: Search :: Login/Register
[2427] Latest edit on 2016-05-13 17:05:36 by BrianKoontz [typo]


Additions:
Forced links using a space separator (<tt>My home page</tt>) have been deprecated since 1.3.1. They are now largely nonfunctional as of this version. See the upgrade instructions below for more details.
Deletions:
Forced links using a space separator ([[HomePage My home page]]) have been deprecated since 1.3.1. They are now largely nonfunctional as of this version. See the upgrade instructions below for more details.


[2426] Edited on 2016-05-13 17:05:14 by BrianKoontz [updated]


Additions:
<b>Old-style forced links now largely nonfunctional</b><br/>
Deletions:
<b>Old-style forced links now largely nonfunctional</b>


[2425] Edited on 2016-05-13 17:05:00 by BrianKoontz [updated]


Additions:
<b>Old-style forced links now largely nonfunctional</b>
Forced links using a space separator ([[HomePage My home page]]) have been deprecated since 1.3.1. They are now largely nonfunctional as of this version. See the upgrade instructions below for more details.
Forced links using a space separator ([[HomePage My home page]]) have been deprecated since 1.3.1. They are now largely nonfunctional as of this version. You will need to modify your forced links and use the | symbol as the separator ([[HomePage | My home page]]). You can either do this manually, or use a script that can be found in the scripts/ directory. If you use the script, it will make a backup of your current database, but it's always a good idea to back up your database whenever you make any system changes. It is not currently integrated in the installer, so you will need command-line access to perform the link migration. Navigate to your top-level wikka directory and invoke:

Deletions:
Forced links using a space separator (##[[HomePage My home page]]##) have been deprecated since 1.3.1. They are now largely unfunctional as of this version. You will need to modify your forced links and use the | symbol as the separator (##[[HomePage | My home page]]##). You can either do this manually, or use a script that can be found in the scripts/ directory. If you use the script, it will make a backup of your current database, but it's always a good idea to back up your database whenever you make any system changes. It is not currently integrated in the installer, so you will need command-line access to perform the link migration. Navigate to your top-level wikka directory and invoke:


[2424] Edited on 2016-05-13 17:02:38 by BrianKoontz [updated]


Additions:
This release has been tested with MySQL 5.5.43 and PHP 5.5.9. Please note that if you are using a version of PHP < 5.4, breadcrumbs must be disabled (<tt>'enable_breadrumbs' => '0'</tt> in <tt>wikka.config.php</tt>).
<b>Upgrading from 1.1.x to 1.3.7</b><br/>
<b>Upgrading from 1.2 to 1.3.7</b><br/>

Upgrading from 1.2 or earlier

Upgrading from 1.3.5 or earlier

Forced links using a space separator (##[[HomePage My home page]]##) have been deprecated since 1.3.1. They are now largely unfunctional as of this version. You will need to modify your forced links and use the | symbol as the separator (##[[HomePage | My home page]]##). You can either do this manually, or use a script that can be found in the scripts/ directory. If you use the script, it will make a backup of your current database, but it's always a good idea to back up your database whenever you make any system changes. It is not currently integrated in the installer, so you will need command-line access to perform the link migration. Navigate to your top-level wikka directory and invoke:
php scripts/migrateDeprecatedLinks.php

(Thanks to klenwell for implementing this!)
We have moved our repository and issues tracker to github. Links to the previous SVN repository and tracker will at some point fail to resolve. Feedback on potential issues related to upgrading from previous versions is always welcome. Please report any bug, issue or feature suggestions in the issues tracker.

Deletions:
This release has been tested with MySQL 5.5 and PHP 5.4. Please note that if you are using a version of PHP < 5.4, breadcrumbs must be disabled (<tt>'enable_breadrumbs' => '0'</tt> in <tt>wikka.config.php</tt>).
<b>Upgrading from 1.1.x to 1.3.6</b><br/>
<b>Upgrading from 1.2 to 1.3.6</b><br/>

Upgrading from 1.2

We have moved our repository and issues tracker to github. Links to the previous SVN repository and tracker will at some point fail to resolve. Feedback on potential issues related to upgrading from previous versions is always welcome. Please report any bug, issue or feature suggestion for 1.3.6 in the issues tracker.



[2423] Edited on 2016-05-13 16:56:39 by BrianKoontz [update]


Additions:

Installation and upgrade notes for Wikka 1.3.7

These are instructions you should follow if you wish to upgrade an existing wiki running on Wikka 1.2 or earlier to 1.3.7. If you are installing Wikka for the first time, please refer to this page instead.

Deletions:

Installation and upgrade notes for Wikka 1.3.6

These are instructions you should follow if you wish to upgrade an existing wiki running on Wikka 1.2 or earlier to 1.3.6. If you are installing Wikka for the first time, please refer to this page instead.



[2422] The oldest known version of this page was created on 2016-05-13 16:55:53 by BrianKoontz [Cloned from Installing136]

History of recent changes for Installing137

Installation and upgrade notes for Wikka 1.3.6


These are instructions you should follow if you wish to upgrade an existing wiki running on Wikka 1.2 or earlier to 1.3.6. If you are installing Wikka for the first time, please refer to this page instead.

Important notes

Requirements
This release has been tested with MySQL 5.5 and PHP 5.4. Please note that if you are using a version of PHP < 5.4, breadcrumbs must be disabled ('enable_breadrumbs' => '0' in wikka.config.php).

Upgrading from 1.1.x to 1.3.6
As of 1.2, WikkaWiki incorporates new support for modularized themes. A new file hierarchy has been introduced, and the old css/ directory is going away. It is imperative that you make a backup of your css/ and templates/ directory BEFORE attempting to upgrade, if you have customized your site theme! Failure to do so will most likely result in a loss of part or all of your theme changes. It's always good practice to back up both your Wikka install directory and your database prior to any upgrades.

Since 1.1.6.6 WikkaWiki has supported a plugins/ directory that is guaranteed not to be modified by the installer/updater. While it's important to backup any customized themes or actions, you should really be putting these into the plugins/ directory.

Upgrading from 1.2 to 1.3.6
Some CSS changes have been made to the themes, so as always, please make a backup of your default, light, and/or kubric themes if you have customized them.

Also, the 1.3.6 installer now backs up the standard installed files in config/, as these have changed significantly. If you have modified your menus, you will have to manually merge your changes into the new installed config/ files.



See also:
Users running previous versions of Wikka are recommended to upgrade or install a fresh package. Upgrading via the web-based wizard takes only a few minutes.

Upgrading from 1.1.6.7 or earlier

Significant changes were made in 1.2, so you're advised to scan through the 1.2 installation notes prior to upgrading. Please be sure to read the important upgrade notice at the top of this page before proceeding.

Upgrading from 1.2

To upgrade from a previous 1.2 or earlier install, simply overwrite all existing files from the installation with a fresh 1.2 download. The upgrader will be invoked so you can verify existing DB and/or config settings. Please be sure to read the important upgrade notice at the top of this page before proceeding.

Feedback

We have moved our repository and issues tracker to github. Links to the previous SVN repository and tracker will at some point fail to resolve. Feedback on potential issues related to upgrading from previous versions is always welcome. Please report any bug, issue or feature suggestion for 1.3.6 in the issues tracker.


CategoryEN
Creative Common Attribution-ShareAlike License
Valid XHTML 1.0 Transitional :: Valid CSS :: Powered by WikkaWiki
Page was generated in 0.0163 seconds